CompTIA Network+ N10-009 Preparation Details
This CompTIA Network+ N10-009 study guide covers all five exam domains, from networking concepts to troubleshooting. Each objective links to official documentation and standards so you can prepare with confidence. You can also explore more CompTIA certification study guides on the CompTIA category to keep building your skills.
CompTIA Network+ Materials
| Coursera | CompTIA Network+ (N10-009): The Total Guide |
| Udemy | CompTIA Network+ N10-009 Courses |
| Whizlabs | CompTIA Network+ (N10-008) |
1.0 Networking Concepts (23%)
1.1 Explain concepts related to the Open Systems Interconnection (OSI) reference model.
Layer 1 – Physical
Ethernet Through the Years: Celebrating the Technology’s 50th Year of Innovation
The FOA Reference For Fiber Optics – Optical Fiber
The FOA Reference For Fiber Optics – Fiber Optic Cables
Layer 2 – Data link
RFC 826: An Ethernet Address Resolution Protocol
Layer 3 – Network
RFC 792: Internet Control Message Protocol
RFC 8200: Internet Protocol, Version 6 (IPv6) Specification
RFC 1812: Requirements for IP Version 4 Routers
Azure virtual network traffic routing
Layer 4 – Transport
RFC 793: Transmission Control Protocol
RFC 768: User Datagram Protocol
RFC 9293: Transmission Control Protocol (TCP)
RFC 4960: Stream Control Transmission Protocol
Layer 5 – Session
RFC 3261: SIP: Session Initiation Protocol
What is SMB File Sharing for Windows and Windows Server?
Remote Desktop Services overview in Windows Server
Layer 6 – Presentation
RFC 8446: The Transport Layer Security (TLS) Protocol Version 1.3
Guidelines for the Selection, Configuration, and Use of TLS Implementations
Layer 7 – Application
RFC 1035: Domain names – implementation and specification
RFC 5321: Simple Mail Transfer Protocol
RFC 959: File Transfer Protocol
What is Domain Name System (DNS)?
1.2 Compare and contrast networking appliances, applications, and functions.
Physical and virtual appliances
RFC 1812: Requirements for IP Version 4 Routers
Guidelines on Firewalls and Firewall Policy
Guide to Intrusion Detection and Prevention Systems (IDPS)
What is Elastic Load Balancing?
What is Amazon Elastic File System?
What is SMB File Sharing for Windows and Windows Server?
What is Amazon FSx for NetApp ONTAP?
RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol
RFC 5415: Control And Provisioning of Wireless Access Points (CAPWAP)
Applications
What is a content delivery network on Azure?
Functions
RFC 2474: Definition of the Differentiated Services Field (DS Field)
RFC 8200: Internet Protocol, Version 6 (IPv6) Specification
RFC 1035: Domain names – implementation and specification
1.3 Summarize cloud concepts and connectivity options.
Network functions virtualization (NFV)
What is a Gateway Load Balancer?
RFC 7665: Service Function Chaining (SFC) Architecture
Virtual private cloud (VPC)
What is Azure Virtual Network?
Network security groups
Control traffic to your AWS resources using security groups
Azure network security groups overview
Network security lists
Control subnet traffic with network access control lists
Cloud gateways
Enable internet access for a VPC using an internet gateway
Cloud connectivity options
Deployment models
The NIST Definition of Cloud Computing
Service models
The NIST Definition of Cloud Computing
Scalability
Six advantages of cloud computing
What is Amazon EC2 Auto Scaling?
What are Virtual Machine Scale Sets?
Elasticity
What is Amazon EC2 Auto Scaling?
What are Virtual Machine Scale Sets?
Multitenancy
Architect multitenant solutions on Azure
SaaS and multitenant solution architecture
1.4 Explain common networking ports, protocols, services, and traffic types.
Protocols and ports
RFC 959: File Transfer Protocol
RFC 4251: The Secure Shell (SSH) Protocol Architecture
RFC 1350: The TFTP Protocol (Revision 2)
RFC 5321: Simple Mail Transfer Protocol
RFC 1035: Domain names – implementation and specification
RFC 2131: Dynamic Host Configuration Protocol
RFC 5905: Network Time Protocol Version 4: Protocol and Algorithms Specification
RFC 3411: An Architecture for Describing SNMP Management Frameworks
RFC 4510: Lightweight Directory Access Protocol (LDAP)
RFC 8446: The Transport Layer Security (TLS) Protocol Version 1.3
What is SMB File Sharing for Windows and Windows Server?
RFC 8314: Cleartext Considered Obsolete
Remote Desktop Services overview in Windows Server
RFC 3261: SIP: Session Initiation Protocol
Internet Protocol (IP) types
RFC 792: Internet Control Message Protocol
RFC 793: Transmission Control Protocol
RFC 768: User Datagram Protocol
RFC 2784: Generic Routing Encapsulation (GRE)
RFC 4301: Security Architecture for the Internet Protocol
RFC 4302: IP Authentication Header
RFC 4303: IP Encapsulating Security Payload (ESP)
RFC 7296: Internet Key Exchange Protocol Version 2 (IKEv2)
Traffic types
RFC 1112: Host extensions for IP multicasting
RFC 919: Broadcasting Internet Datagrams
RFC 4786: Operation of Anycast Services
RFC 5771: IANA Guidelines for IPv4 Multicast Address Assignments
1.5 Compare and contrast transmission media and transceivers.
Wireless
IEEE 802.11, The Working Group Setting the Standards for Wireless LANs
Guidelines for Securing Wireless Local Area Networks (WLANs)
Wired
Ethernet Through the Years: Celebrating the Technology’s 50th Year of Innovation
The FOA Reference For Fiber Optics – Optical Fiber
The FOA Reference For Fiber Optics – Fiber Optic Cables
Transceivers
The FOA Reference For Fiber Optics – Optical Fiber
Ethernet Through the Years: Celebrating the Technology’s 50th Year of Innovation
Connector types
Fiber Optic Connector Identifier
The FOA Reference For Fiber Optics – Fiber Optic Cables
1.6 Compare and contrast network topologies, architectures, and types.
Mesh
What is AWS Transit Gateway for Amazon VPC?
Hybrid
Hub-spoke network topology in Azure
What is AWS Transit Gateway for Amazon VPC?
Star/hub and spoke
Hub-spoke network topology in Azure
What is AWS Transit Gateway for Amazon VPC?
Spine and leaf
RFC 7938: Use of BGP for Routing in Large-Scale Data Centers
RFC 7348: Virtual eXtensible Local Area Network (VXLAN)
Point to point
Ethernet Through the Years: Celebrating the Technology’s 50th Year of Innovation
Three-tier hierarchical model
Hub-spoke network topology in Azure
RFC 7938: Use of BGP for Routing in Large-Scale Data Centers
Collapsed core
Hub-spoke network topology in Azure
RFC 7938: Use of BGP for Routing in Large-Scale Data Centers
Traffic flows
Hub-spoke network topology in Azure
1.7 Given a scenario, use appropriate IPv4 network addressing.
Public vs. private
RFC 1918: Address Allocation for Private Internets
RFC 3927: Dynamic Configuration of IPv4 Link-Local Addresses
RFC 6890: Special-Purpose IP Address Registries
RFC 1122: Requirements for Internet Hosts – Communication Layers
Subnetting
RFC 4632: Classless Inter-domain Routing (CIDR)
RFC 1878: Variable Length Subnet Table For IPv4
IPv4 address classes
RFC 5771: IANA Guidelines for IPv4 Multicast Address Assignments
RFC 1112: Host extensions for IP multicasting
RFC 6890: Special-Purpose IP Address Registries
1.8 Summarize evolving use cases for modern network environments.
Software-defined network (SDN) and software-defined wide area network (SD-WAN)
RFC 7426: Software-Defined Networking (SDN): Layers and Architecture Terminology
RFC 8572: Secure Zero Touch Provisioning (SZTP)
Virtual Extensible Local Area Network (VXLAN)
RFC 7348: Virtual eXtensible Local Area Network (VXLAN)
Virtual eXtensible Local Area Networking documentation
Zero trust architecture (ZTA)
Zero Trust as a security foundation
Secure Access Secure Edge (SASE)/Security Service Edge (SSE)
Zero Trust as a security foundation
Infrastructure as code (IaC)
Working with dynamic inventory
Validating tasks: check mode and diff mode
1.3 Getting Started – What is Git?
1.1 Getting Started – About Version Control
2.5 Git Basics – Working with Remotes
3.1 Git Branching – Branches in a Nutshell
3.2 Git Branching – Basic Branching and Merging
IPv6 addressing
RFC 4291: IP Version 6 Addressing Architecture
RFC 8200: Internet Protocol, Version 6 (IPv6) Specification
RFC 4213: Basic Transition Mechanisms for IPv6 Hosts and Routers
RFC 6144: Framework for IPv4/IPv6 Translation
RFC 7915: IP/ICMP Translation Algorithm
RFC 6269: Issues with IP Address Sharing
What is IPv6 for Azure Virtual Network?
2.0 Network Implementation (20%)
2.1 Explain characteristics of routing technologies.
Static routing
ip-route(8) — Linux manual page
Azure virtual network traffic routing
Dynamic routing
RFC 4271: A Border Gateway Protocol 4 (BGP-4)
RFC 7868: Cisco’s Enhanced Interior Gateway Routing Protocol (EIGRP)
Route selection
RFC 1812: Requirements for IP Version 4 Routers
ip-route(8) — Linux manual page
Azure virtual network traffic routing
Address translation
RFC 3022: Traditional IP Network Address Translator (Traditional NAT)
RFC 2663: IP Network Address Translator (NAT) Terminology and Considerations
RFC 4787: Network Address Translation (NAT) Behavioral Requirements
First Hop Redundancy Protocol (FHRP)
RFC 5798: Virtual Router Redundancy Protocol (VRRP) Version 3 for IPv4 and IPv6
RFC 2281: Cisco Hot Standby Router Protocol (HSRP)
Virtual IP (VIP)
RFC 5798: Virtual Router Redundancy Protocol (VRRP) Version 3 for IPv4 and IPv6
Subinterfaces
ip-link(8) — Linux manual page
2.2 Given a scenario, configure switching technologies and features.
Virtual Local Area Network (VLAN)
ip-link(8) — Linux manual page
Azure Virtual Network frequently asked questions (FAQ)
Interface configuration
802.1X – Port Based Network Access Control
Linux Ethernet Bonding Driver HOWTO
Spanning tree
802.1w – Rapid Reconfiguration of Spanning Tree
802.1s – Multiple Spanning Trees
Maximum transmission unit (MTU)
RFC 4821: Packetization Layer Path MTU Discovery
Network maximum transmission unit (MTU) for your EC2 instance
TCP/IP performance tuning for Azure VMs
ip-link(8) — Linux manual page
2.3 Given a scenario, select and configure wireless devices and technologies.
Channels
IEEE 802.11, The Working Group Setting the Standards for Wireless LANs
hostapd: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/WPA3/EAP/RADIUS Authenticator
Guidelines for Securing Wireless Local Area Networks (WLANs)
Frequency options
IEEE 802.11, The Working Group Setting the Standards for Wireless LANs
hostapd: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/WPA3/EAP/RADIUS Authenticator
Service set identifier (SSID)
IEEE 802.11, The Working Group Setting the Standards for Wireless LANs
hostapd: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/WPA3/EAP/RADIUS Authenticator
Linux WPA Supplicant (IEEE 802.1X, WPA, WPA2, WPA3, RSN, IEEE 802.11i)
Network types
IEEE 802.11, The Working Group Setting the Standards for Wireless LANs
Guidelines for Securing Wireless Local Area Networks (WLANs)
Encryption
Establishing Wireless Robust Security Networks: A Guide to IEEE 802.11i
Guidelines for Securing Wireless Local Area Networks (WLANs)
hostapd: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/WPA3/EAP/RADIUS Authenticator
Guest networks
RFC 8910: Captive-Portal Identification in DHCP and Router Advertisements (RAs)
Authentication
RFC 3748: Extensible Authentication Protocol (EAP)
Extensible Authentication Protocol (EAP) for network access
hostapd: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/WPA3/EAP/RADIUS Authenticator
Antennas
IEEE 802.11, The Working Group Setting the Standards for Wireless LANs
Guidelines for Securing Wireless Local Area Networks (WLANs)
Establishing Wireless Robust Security Networks: A Guide to IEEE 802.11i
Autonomous vs. lightweight AP
RFC 5415: Control And Provisioning of Wireless Access Points (CAPWAP)
RFC 5412: Lightweight Access Point Protocol
IEEE 802.11, The Working Group Setting the Standards for Wireless LANs
2.4 Explain important factors of physical installations.
Important installation implications
The FOA Reference For Fiber Optics – Fiber Optic Cables
Azure facilities, premises, and physical security
Power
Azure facilities, premises, and physical security
Security and Privacy Controls for Information Systems and Organizations
Environmental factors
Azure facilities, premises, and physical security
Security and Privacy Controls for Information Systems and Organizations
3.0 Network Operations (19%)
3.1 Explain the purpose of organizational processes and procedures.
Documentation
Guide for Security-Focused Configuration Management of Information Systems
Amazon Compute Service Level Agreement
baseline configuration – Glossary
Life-cycle management
Overview – Product End of Support & Retirements
Guide to Enterprise Patch Management Planning
Guidelines for Media Sanitization
Change management
Guide for Security-Focused Configuration Management of Information Systems
Security and Privacy Controls for Information Systems and Organizations
Configuration management
Guide for Security-Focused Configuration Management of Information Systems
baseline configuration – Glossary
3.2 Given a scenario, use network monitoring technologies.
Methods
RFC 3411: An Architecture for Describing SNMP Management Frameworks
RFC 3414: User-based Security Model (USM) for SNMPv3
RFC 1901: Introduction to Community-based SNMPv2
RFC 1213: Management Information Base for Network Management
RFC 3954: Cisco Systems NetFlow Services Export Version 9
RFC 7011: Specification of the IP Flow Information Export (IPFIX) Protocol
Logging IP traffic using VPC Flow Logs
Guide to Computer Security Log Management
What is Microsoft Sentinel security information and event management (SIEM)?
Security Information and Event Management – Glossary
RFC 6241: Network Configuration Protocol (NETCONF)
Solutions
Chapter 15. Nmap Reference Guide
What are Azure Monitor alerts?
3.3 Explain disaster recovery (DR) concepts.
DR metrics
Recovery Point Objective – Glossary
Recovery Time Objective – Glossary
Architecture strategies for defining reliability targets
Contingency Planning Guide for Federal Information Systems
DR sites
Contingency Planning Guide for Federal Information Systems
Disaster recovery options in the cloud
High-availability approaches
Reliability Pillar – AWS Well-Architected Framework
What are business continuity, high availability, and disaster recovery?
Using availability zones and regions
Testing
Guide to Test, Training, and Exercise Programs for IT Plans and Capabilities
Contingency Planning Guide for Federal Information Systems
Architecture strategies for disaster recovery
3.4 Given a scenario, implement IPv4 and IPv6 network services.
Dynamic addressing
RFC 2131: Dynamic Host Configuration Protocol
RFC 2132: DHCP Options and BOOTP Vendor Extensions
RFC 3046: DHCP Relay Agent Information Option
RFC 4862: IPv6 Stateless Address Autoconfiguration
RFC 8415: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
What is Dynamic Host Configuration Protocol (DHCP) Server in Windows Server?
Kea Administrator Reference Manual
Name resolution
RFC 1034: Domain names – concepts and facilities
RFC 1035: Domain names – implementation and specification
RFC 4033: DNS Security Introduction and Requirements
RFC 8484: DNS Queries over HTTPS (DoH)
RFC 7858: Specification for DNS over Transport Layer Security (TLS)
RFC 3596: DNS Extensions to Support IP Version 6
Manage DNS zones using DNS server in Windows Server
Overview of DNS zones and records
Secure Domain Name System (DNS) Deployment Guide
What is Domain Name System (DNS)?
Time protocols
RFC 5905: Network Time Protocol Version 4: Protocol and Algorithms Specification
RFC 8915: Network Time Security for the Network Time Protocol
Windows Time Service (W32Time)
NIST Internet Time Service (ITS)
802.1AS – Timing and Synchronization
ptp4l(8): PTP Boundary/Ordinary/Transparent Clock
3.5 Compare and contrast network access and management methods.
Site-to-site VPN
Client-to-site VPN
WireGuard: fast, modern, secure VPN tunnel
Split-tunnel on AWS Client VPN endpoints
Microsoft Entra application proxy
Overview: VPN split tunneling for Microsoft 365
Connection methods
RFC 4251: The Secure Shell (SSH) Protocol Architecture
Remote Desktop Services overview in Windows Server
RFC 6241: Network Configuration Protocol (NETCONF)
Jump box/host
AWS Systems Manager Session Manager
In-band vs. out-of-band management
4.0 Network Security (14%)
4.1 Explain the importance of basic network security concepts.
Logical security
Guidelines for the Selection, Configuration, and Use of TLS Implementations
What is Active Directory Certificate Services?
public key infrastructure (PKI) – Glossary
Self-signed certificate – Glossary
How it works: Microsoft Entra multifactor authentication
What is single sign-on in Microsoft Entra ID?
role-based access control (RBAC) – Glossary
What is Azure role-based access control (Azure RBAC)?
RFC 2865: Remote Authentication Dial In User Service (RADIUS)
RFC 8907: The TACACS+ Protocol
RFC 4510: Lightweight Directory Access Protocol (LDAP)
Conditional Access: Network assignment
Physical security
Guidelines for the Use of PIV Credentials in Facility Access
Azure facilities, premises, and physical security
Security and Privacy Controls for Information Systems and Organizations
Deception technologies
Common security terminology
Guide for Conducting Risk Assessments
Audits and regulatory compliance
General Data Protection Regulation
PCI Security Standards Council – Protect Payment Data
Network segmentation enforcement
Guide to Operational Technology (OT) Security
What is Microsoft Defender for IoT?
Foundational Cybersecurity Activities for IoT Device Manufacturers
Bring Your Own Device – Glossary
Establishing Wireless Robust Security Networks: A Guide to IEEE 802.11i
Hub-spoke network topology in Azure
4.2 Summarize various types of attacks and their impact to the network.
Denial-of-service (DoS)/distributed denial-of-service (DDoS)
Understanding Denial-of-Service Attacks
Understanding and Responding to Distributed Denial-Of-Service Attacks
How AWS Shield and Shield Advanced work
What is Azure DDoS Protection?
denial of service (DoS) – Glossary
VLAN hopping
Media Access Control (MAC) flooding
802.1X – Port Based Network Access Control
Address Resolution Protocol (ARP) poisoning
RFC 826: An Ethernet Address Resolution Protocol
man-in-the-middle attack (MitM) – Glossary
ARP spoofing
RFC 826: An Ethernet Address Resolution Protocol
man-in-the-middle attack (MitM) – Glossary
DNS poisoning
Secure Domain Name System (DNS) Deployment Guide
RFC 4033: DNS Security Introduction and Requirements
DNS spoofing
Secure Domain Name System (DNS) Deployment Guide
RFC 4033: DNS Security Introduction and Requirements
Rogue devices and services
RFC 3046: DHCP Relay Agent Information Option
802.1X – Port Based Network Access Control
Establishing Wireless Robust Security Networks: A Guide to IEEE 802.11i
Evil twin
Establishing Wireless Robust Security Networks: A Guide to IEEE 802.11i
Guidelines for Securing Wireless Local Area Networks (WLANs)
On-path attack
man-in-the-middle attack (MitM) – Glossary
Guidelines for the Selection, Configuration, and Use of TLS Implementations
Social engineering
Avoiding Social Engineering and Phishing Attacks
Guidelines for the Use of PIV Credentials in Facility Access
Malware
Protecting Against Malicious Code
Microsoft Defender for Endpoint overview
4.3 Given a scenario, apply network security features, defense techniques, and solutions.
Device hardening
Security and Privacy Controls for Information Systems and Organizations
Network access control (NAC)
802.1X – Port Based Network Access Control
Network Access Control (NAC) – Glossary
Extensible Authentication Protocol (EAP) for network access
RFC 3748: Extensible Authentication Protocol (EAP)
Key management
Recommendation for Key Management: Part 1 – General
Security rules
access control list – Glossary
Control subnet traffic with network access control lists
Azure network security groups overview
Guidelines on Firewalls and Firewall Policy
Using DNS Firewall to filter outbound DNS traffic
Zones
demilitarized zone (DMZ) – Glossary
Guidelines on Firewalls and Firewall Policy
Implement a secure hybrid network
5.0 Network Troubleshooting (24%)
5.1 Explain the troubleshooting methodology.
Identify the problem
Connection troubleshoot overview
What is Azure Network Watcher?
Incident Response Recommendations and Considerations
Establish a theory of probable cause
Diagnose a virtual machine routing problem
Diagnose a virtual machine network traffic filter problem
What is Azure Network Watcher?
Test the theory to determine the cause
Establish a plan of action to resolve the problem and identify potential effects
Guide for Security-Focused Configuration Management of Information Systems
Guide to Enterprise Patch Management Planning
Implement the solution or escalate as necessary
Guide for Security-Focused Configuration Management of Information Systems
Incident Response Recommendations and Considerations
Verify full system functionality and implement preventive measures if applicable
What is Azure Network Watcher?
Document findings, actions, outcomes, and lessons learned throughout the process
Incident Response Recommendations and Considerations
Guide for Security-Focused Configuration Management of Information Systems
5.2 Given a scenario, troubleshoot common cabling and physical interface issues.
Cable issues
The FOA Reference For Fiber Optics – Fiber Optic Cables
The FOA Reference For Fiber Optics – Optical Fiber
Interface issues
ip-link(8) — Linux manual page
Hardware issues
Ethernet Through the Years: Celebrating the Technology’s 50th Year of Innovation
5.3 Given a scenario, troubleshoot common issues with network services.
Switching issues
Diagnose a virtual machine network traffic filter problem
access control list – Glossary
Route selection
ip-route(8) — Linux manual page
Diagnose a virtual machine routing problem
Address pool exhaustion
What is Dynamic Host Configuration Protocol (DHCP) Server in Windows Server?
RFC 2131: Dynamic Host Configuration Protocol
Kea Administrator Reference Manual
Incorrect default gateway
ip-route(8) — Linux manual page
Incorrect IP address
RFC 5227: IPv4 Address Conflict Detection
ip-address(8) — Linux manual page
Incorrect subnet mask
RFC 4632: Classless Inter-domain Routing (CIDR)
5.4 Given a scenario, troubleshoot common performance issues.
Congestion/contention
RFC 2914: Congestion Control Principles
RFC 5681: TCP Congestion Control
Bottlenecking
iPerf – The ultimate speed test tool for TCP, UDP and SCTP
Virtual machine network bandwidth
Network adapter performance tuning in Windows Server
Bandwidth
Virtual machine network bandwidth
Amazon EC2 instance network bandwidth
Latency
RFC 2679: A One-way Delay Metric for IPPM
Test network latency between Azure VMs
Packet loss
RFC 7680: A One-Way Loss Metric for IP Performance Metrics (IPPM)
Jitter
RFC 3393: IP Packet Delay Variation Metric for IP Performance Metrics (IPPM)
RFC 3550: RTP: A Transport Protocol for Real-Time Applications
Wireless
Guidelines for Securing Wireless Local Area Networks (WLANs)
Establishing Wireless Robust Security Networks: A Guide to IEEE 802.11i
IEEE 802.11, The Working Group Setting the Standards for Wireless LANs
5.5 Given a scenario, use the appropriate tool or protocol to solve networking issues.
Software tools
Chapter 15. Nmap Reference Guide
802.1AB – Station and Media Access Control Connectivity Discovery
Hardware tools
The FOA Reference For Fiber Optics – Optical Fiber
The FOA Reference For Fiber Optics – Fiber Optic Cables
Basic networking device commands
Wrapping Up CompTIA Network+ N10-009
Work through every N10-009 objective in this CompTIA Network+ study guide, using the linked vendor documentation and standards to reinforce each topic. Hands-on practice with real tools makes the troubleshooting and security scenarios far easier to handle on exam day. Good luck with your certification! You can also explore more CompTIA certification study guides on the CompTIA category to keep building your skills. Have a question or tip? Leave a comment below.
Receive Updates on CompTIA Network+ Exam
Want to be notified as soon as I post? Subscribe to the RSS feed / leave your email address in the subscribe section. Share the article to your social networks with the below links so it can benefit others.